You are Unregistered, please register to be able to read posts in all forums and participate in the discussion.
Results 1 to 5 of 5

Thread: need help

Hybrid View

  1. #1
    Junior Member
    Join Date
    Jul 2009
    Posts
    6

    Default need help

    i'm having problems with my string jumping on the other side of my cable gaurd bar. the bow is a golden eagle and just started happening a month ago. i have bought a new bow but would like to keep the old one for back up. any help would be great. thanks

  2. #2
    Senior Member Ancient Archer's Avatar
    Join Date
    Sep 2008
    Location
    NH
    Posts
    167

    Default

    Did you recently make any "adjustments" to your bow? It's not likely that the bow should just suddenley change the way it shoots. Did you do anything at all with the cable slide, like install it backwards, or are the string and cables located properly in the cam slots? Does the bow draw differently than before? It sounds like you may have made somechange to the bow???
    "A Nation of Sheep Breeds a Government of Wolves!"
    2007/2008 Commander: 60lb/28" DL, HHA OL5519, Code Red, Choc Addiction, .400 Axis, Self-made Shoot-Thru
    2010 Elite GT500: 60lb/HHA DS5500, QAD UltraRest HD Pro Series, Victory VForce HV 400
    1965 Bear Kodiak Magnum Recurve 50lb, 52", Original Bear Quiver & Cedar Arrows

  3. #3
    Junior Member
    Join Date
    Jul 2009
    Posts
    6

    Default

    I had the bow shop put on a wisker biscuit and a new string on. After that the bow was shooting fine. I talked to someone else and they think that i may have altered the way i shoot. i did also noticed that the sting cable gaurd bar looks slightly tweaked toward the string but when i take it off and examine it, it looks straight. should i try a new cable gaurd bar?

  4. #4
    Junior Member
    Join Date
    Feb 2010
    Posts
    8

    Default

    Is the bow a split limb, i had similar problems with my cam but either way it was do to the limb being twisted. i was having problems with mine and that was the cause. The twist on it is almost impossible to see you really have to examine it.

  5. #5
    Junior Member
    Join Date
    Feb 2010
    Location
    Burma
    Posts
    3

    Default need help

    hello all
    i have been modeling for a while now and i was wundering is it possible to turn off mirror after a model is done or i just dont need it with out getting rid of the side i have mirrored ?
    any help is much apreciated
    o i almost forgot dose mirror also cause your bone x axis mirror to not appear that it is working cause when ever i use mirror and x axis mirror for the armetures they dont show up on the right side of my models?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •