Archery Forums 3DShoots.com
Find Archery Shoots near you  |   Advertise on 3DShoots.com

Go Back   Archery Forums 3DShoots.com > Archery Forum > General Archery Forum
 

Reply
 
Thread Tools Display Modes
Old 05-09-2006, 06:35 PM   #1
12ring4me
Member
 
Join Date: Apr 2006
Location: Missouri
Posts: 70
12ring4me is on a distinguished road
Default Question about fletching glue.

Hey fellas,
Well first off I should say long time no chat, I have been a little busy to write so here it goes. I got my new Hogg It sighted in, man what a sight. Enough said about that. Now to my problem I am having. I have been using Fast Set Gel glue to fletch my arrows and I notice that when I took one of my arrows out of the jig there was a bunch of white reidue between the vanes. Is this due to the cyanoacrilite or what ever that big word is causing this. Is that a sign of to much glue being used on my vanes, or is it a cleaning problem that needs to be addressed on the arrow shaft. I fletch with blazers, and specs say that vanes need not to be cleaned before fletching. Next question, is there any way to get this residue off, I know that it is just a cosmetic ordeal, but it sure looks ugly, and it appears that you dont know what you are doing when it comes to fletching.. Please give me some insight on this problem.
__________________
Switchback 28"
Scott Longhorn III
Scott Mongoose
Easton Fatboy 400 (344 grains- 260fps@58lbs)
Specialty Archery Superstix
NAP Drop way
Sims Vibration
Spot Hogg Sights

"A bad day of target shooting is still better than a good day of work".
12ring4me is offline   Reply With Quote
Old 05-09-2006, 07:59 PM   #2
BUNNYMAN
I pray for you!
 
BUNNYMAN's Avatar
 
Join Date: Apr 2005
Location: the Hutch
Posts: 29,888
BUNNYMAN will become famous soon enoughBUNNYMAN will become famous soon enough
Default

I used to have the same problem, not sure what the answer is but I started using Flex-Bond adhesive by Flex-Fletch Products and I have not had the problem since. takes a little longer to dry but I have never had to fletch Arrows the morning of a shoot either
__________________
I cut things up and split them down!
BUNNYMAN is online now   Reply With Quote
Old 05-09-2006, 11:01 PM   #3
3dhunter
Member
 
Join Date: Mar 2006
Location: NW Iowa
Posts: 61
3dhunter is on a distinguished road
Send a message via Yahoo to 3dhunter
Default Glue problem?

I've used Fletch-Tite for over ten years and never had a problem, okay one; I left the glue in a spot where it froze. I've used Tip Grip for the past year and it's been great as well.

Did you keep the glue in a high moisure area, was it sealed tight or did it get cold? The Cyanoacrylate adhesives bond can be weakened, allowing disassembly, by placing the glued object in a household freezer for several hours.
__________________
Keith
NBEF Instructor
South Dakota - Iowa
3dhunter is offline   Reply With Quote
Old 05-10-2006, 06:36 AM   #4
CSS Shooter
Senior Member
 
Join Date: Jan 2006
Location: Cowden IL
Posts: 424
CSS Shooter is on a distinguished road
Default

Are you using Goat Tuff glue? I have seen this happen with that product. I use AAE Quick Set Gel and have never had a problem.
__________________

2012 Bow Tech Pro Staff
Sword Pro Staff Vane Tech Pro Staff
Gold Tip Factory Staff Coffey marketing
A.S.A. IL. State Director
CSS Shooter is offline   Reply With Quote
Old 05-12-2006, 06:51 PM   #5
John-in-VA
Junior Member
 
Join Date: Feb 2006
Location: Bedford VA
Posts: 14
John-in-VA is on a distinguished road
Default

I have had that happen also .I started useing loc tight super gel .With the blazers I light sand the shaft's and the bottom of the blazers ,put a small thin line of the glue on and set the clamp .Instent bond ,you can take the clamp off and shoot them . You cant pull them off .Work's the best I have ever tryed and I have tryed them all,AAE fast set gel ,Goat tuff ,Beyond bond ,Platinum .All the other glues work great on other vains but the Blazer's .Just my 2 cent's
John-in-VA is offline   Reply With Quote
Old 05-13-2006, 08:28 AM   #6
Radar
Story of my life
 
Radar's Avatar
 
Join Date: Oct 2005
Location: N. Illinois
Posts: 851
Radar will become famous soon enough
Default Glue problems

I use a fast set glue also and I would get the white residue on there. I came to the conclusion that it was the fumes coming off of the glue on the vane. Because the first time I used it after the arrows were done I put them in my arrow case and the next day I opened the case and the chemical smell in the case was overpowering and ......... white haze on the shaft by the blazers what I actually did was take a wet wash cloth and just wiped it all off. sometimes I had to get a little physical with em had to show who was boss! All fast set glue is is a high powered super glue that is a little thicker in consistency so its easier to use have you ever seen a white haze around something that you have super glued I have plenty of times
__________________
Target: Hoyt ProElite XT3000 C2, 60# 30", CBE Quad Lite, CBE 3x .019, Trophy Taker, Easton Fatboy 400's(indoor) lightspeed 400 (outdoor)

Hunting: 2009 Alphamax35 (Blacked out) 70#, 29", HHA Slider, Bisquit, Easton ACC 3-60, Rage 100 gr. 2 blade
Radar is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2004 3DShoots.com