STS Stopper Issue

Discussion in 'General Archery Forum' started by HOYT4LIFE, Aug 19, 2006.

  1. HOYT4LIFE

    HOYT4LIFE Guest

    Hello, new member here to the forum. You guys seem pretty knowledgeable about the STS so here goes, Front mount STS on Hoyt Magnatec and the stopper keeps popping off when the bow is fired. It does not seem to matter what position I put the rod or stopper in it keeps happening. Some positions are better than others but still the same result eventually. E-mailed the company with no response. Anybody know what to do????????:
     
  2. Dredly

    Dredly Site Guru

    4,358
    3
    0
    pops off? Is the screw that holds it on tight? If it is then contact STS and get a new one, that thing shouldn't come off.
     

  3. Chris

    Chris Administrator Staff Member

    4,078
    5
    38
    First things first, glue it on. The reason it pops off is the extra oscillation of the string after the shot. Sometimes the string will go to the side of the the stopper and pop it off on the way back. Try putting a little extra space between it and the string when not drawn.
     
  4. Dredly

    Dredly Site Guru

    4,358
    3
    0
    I think the general rule of thumb used to be a bent in half business card should be able to fit in between the STS and the string... but I'm not sure if thats the case with the newer STS's (Their instrucstions now specifally tell you to put it right where it is touching on the string)
     
  5. BUNNYMAN

    BUNNYMAN I pray for you!

    29,903
    12
    0
    of course maybe its just because its a HOYT.....:peace: only kidding...

    I have the old one and have it so it is touching the string at rest.....never been a problem.....
     
  6. HOYT4LIFE

    HOYT4LIFE Guest

    Chris, is there a particular type of glue that you would recommend??????
     
  7. Radar

    Radar Story of my life

    851
    2
    0
    Had the same problem. I also have my STS touching the string, put some superglue on the stopper and slid it on the rod that way it got glue all the way in.......have'nt had a problem since.