What the?

Discussion in 'General Archery Forum' started by Dredly, Jan 19, 2007.

  1. Dredly

    Dredly Site Guru

    4,358
    3
    0
    Okay before we start laughing and blasting bowtech somone answer the question first.

    I was just shooting my OG and it felt very strange, a large amount of recoil and noise. So I shot again and the same thing happened only worse. So I looked at my bow and the rod came out that has the cable slide on it.

    wtf?

    So I took out the locking hex screw and put the rod back in however it doesn't seem like it wants to go all the way in and it is still shooting very strange. Any suggestions? (Yes I did put the cables back in the slide correctly)
     
  2. tek

    tek Senior Member

    220
    0
    0
    When you shoot alot something sooner or later will work its way loose.

    I know you said you put the cables back to where they were in the cable slide. But did you cross the cables on the bottom or top. Not real sure about that bow but I would think that they would be crossed on the bottom.
     

  3. Holy Smokes

    Holy Smokes Senior Member

    6,721
    14
    0
    Get you a Martin shoot thru system. No problems like that. HS
     
  4. BUNNYMAN

    BUNNYMAN I pray for you!

    29,903
    12
    0

    Did you take the rod all the way out and check the hole, maybe a small peice broke off in there.....also maybe the rod is slightly bent??
     
  5. Dredly

    Dredly Site Guru

    4,358
    3
    0
    It looks perfectly straight. I'm going to try to remove it again tommorow and make sure... now I can't get the stupid thing out of the riser. grrr

    as for the question about the strings, they are crossing below the cable slide.
     
  6. BUNNYMAN

    BUNNYMAN I pray for you!

    29,903
    12
    0
    it was hard going in and now you are having a hard time getting it out.....sounds bent to me....but what do I know all the bows I have....are roller guards.....
     
  7. Dredly

    Dredly Site Guru

    4,358
    3
    0
    If I remember correctly it was a massive PITA to get out the first time back when I tried using a WindStalker (ate up the cables horrible) so it may just be a bowtech thing. I'm gonna play with it some more and see what happens
     
  8. brokenarrow

    brokenarrow Evil Genius

    5,305
    1
    0
    If the hole in the riser is tight it may have some gall marks on the rod from the lock screw jamming it up
     
  9. longcut36

    longcut36 Senior Member

    3,669
    10
    38
    what brokenarrow said. it doesn't take much of a burr. also the pressure from the set screw can cause a carbon rod to swell some.