BowTech Guardian problems

Discussion in 'General Archery Forum' started by SilentSniper, Jul 18, 2007.

  1. SilentSniper

    SilentSniper Senior Member

    146
    0
    0
    Well my wife and I just had a little girl 3 months ago and the going to the range thing as slowly come to a halt. Not a bad thing. Well I pulled out the old Guardian and the other day and pulled her back. At the very end of the draw cycle right after the cams roll over there is a very loud click. Not a small click.....a big click. Well I took it in today to the archery shop to have them look at it. They told me that they have had a few customers complain about the same thing. Non of those customers have had the problem fixed from what I gathered. Well after a few minutes and a few tries of the proshop fixing the problem I called Bowtech myself. I spoke with a Jeff about the problem. He said that it was a problem and he was going to send me a new module that had a deeper valley. Has anyone else had this problem? Bow shoots great, but I can be clickin in the woods?
     
  2. thehairlessone!

    thehairlessone! Senior Member

    1,003
    0
    0
    SS,
    did you pm bowtech_shooter on AT?

    rick
     

  3. MeanV2

    MeanV2 Senior Member

    1,162
    2
    0
    If he sends you the new mods your problem will be over. It was just the early mods and on certain drawlengths where that would happen. Sounds like your problem will soon be fixed:biggrin1:

    Dan
     
  4. VE6WTF

    VE6WTF Senior Member

    211
    0
    0
  5. Sniper

    Sniper Senior Member

    975
    1
    0
    Evil Incarnate.
     
  6. SinGin

    SinGin Banned

    1,001
    0
    0
    :amen: you got that right
     
  7. Cameron

    Cameron Senior Member

    803
    0
    0

    Can you expand on this? I had this happen, but only once or twice, and I just though it was because I had not shot the bow in a while.
     
  8. SilentSniper

    SilentSniper Senior Member

    146
    0
    0
  9. jcmorgan31

    jcmorgan31 Prodigal Son

    4,569
    4
    0
  10. MeanV2

    MeanV2 Senior Member

    1,162
    2
    0
    Cameron, I think it was with the very 1st mods out and on 29" and longer draws. I could be wrong on the draw length range:noidea:

    Dan
     
  11. Cameron

    Cameron Senior Member

    803
    0
    0
    Well, I have not shot the BT in a few weeks, so we will see if there is an issue on Sunday.

    I have to shoot it anyway, the Conquest feels naked without the CSS.:Cry:
     
  12. showtime hoyt

    showtime hoyt Junior Member

    16
    0
    0
    what causes it?

    a loud click? how can you tell what mods you have? i been thinking about getting a gardian,it super quite.a guy at the range had one and it shounded just like a rubberband shooting off your finger,about that loud.i think bow-tech is on to something.
     
  13. SilentSniper

    SilentSniper Senior Member

    146
    0
    0
    Bowtech sent me new modules and the problem is taken care of. She is nice a quit now. :rockon:
     
  14. MeanV2

    MeanV2 Senior Member

    1,162
    2
    0
    The click noise will occur as you are drawing the bow. If it doesn't you are good to go:cool:

    Dan
     
  15. Cameron

    Cameron Senior Member

    803
    0
    0
    No noise from my Guardian. Quiet as the day it was born.:rockon:
     
  16. thehairlessone!

    thehairlessone! Senior Member

    1,003
    0
    0
    same here. I love that bow more and more every time i shoot it.

    rick
     
  17. QSA

    QSA One eyed/Gutless wonder

    5,998
    1
    0
    AT = Alligator tail? :smokin:
     
  18. dzingale

    dzingale Senior Member

    338
    0
    0
    Why is this old post being brought up after all this time?:noidea:
     
  19. BUNNYMAN

    BUNNYMAN I pray for you!

    29,903
    12
    0
    brand hater????:lol: :lol: :lol: